java: 错误: 不支持发行版本 5

本文阅读 2 分钟
首页 代码,Java 正文

        相信我们程序媛在工作中会经常用到代码生成器,何为代码生成器?简单的说,其实就是帮助我们生成代码的。但是在使用基于FreeMarker代码生成器时,不知道大家有没有报过这样的错误:java: 错误: 不支持发行版本 5?其实很简答,无非就是java版本不支持,那也就是jdk版本不对了。下面是解决步骤:

        点击File——“Project Strucuure”,之后会弹出一个窗口,如下图所示,看到窗口上显示的jdk是11的版本,可是我电脑上没有下载11版本的jdk,这应该是系统自动匹配的吧。把它改成自己电脑上有的版本就行,因为我电脑是1.8版本的,所以我就换成1.8版本的了。

img img         再次运行,就不会报错了。

本文为互联网自动采集或经作者授权后发布,本文观点不代表立场,若侵权下架请联系我们删帖处理!文章出自:https://blog.csdn.net/qq_46540738/article/details/118240606
-- 展开阅读全文 --
安全面试之XSS(跨站脚本攻击)
« 上一篇 07-24

发表评论

成为第一个评论的人

热门文章

标签TAG

最近回复