Error:java: Compilation failed: internal java compiler error

本文阅读 2 分钟
首页 代码,Java 正文

使用Idea导入新项目或升级idea或新建项目时会出现以下异常信息:

Error:java: Compilation failed: internal java compiler error 

导致这个错误的原因主要是因为jdk版本问题,此处有两个原因,一个是编译版本不匹配,一个是当前项目jdk版本不支持。

解决方案如下:

1 查看项目的jdk

File ->Project Structure->Project Settings ->Project或使用快捷键Ctrl+Alt+shift+S打开项目的jdk配置:

img

查看此两处是否与目标jdk一致。

2 查看工程的jdk

点击上图中Modules查看对应jdk版本:

img

3 查看java编译器版本

img

导入java项目时此处处问题的概率比较多。

针对此问题,重新打开或修改pom文件(maven项目)中的内容很可能导致jdk版本重新变为1.5。如果是maven项目,可在pom文件中指定jdk相关信息:

<build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <configuration>
                    <source>1.7</source>
                    <target>1.7</target>
                </configuration>
            </plugin>
        </plugins>
    </build>

如果用的jkd8则<source> <target> 里面写1.8,以此类推。。。

 

 

 

 

本文为互联网自动采集或经作者授权后发布,本文观点不代表立场,若侵权下架请联系我们删帖处理!文章出自:https://wangjiawei.blog.csdn.net/article/details/106851995
-- 展开阅读全文 --
安全面试之XSS(跨站脚本攻击)
« 上一篇 07-24

发表评论

成为第一个评论的人

热门文章

标签TAG

最近回复